GHX Notification: IBR – Order Processing Delays

Incident Report for GHX Customer Status

Update

Dear GHX Customer,

GHX is continuing to investigate a temporary disruption affecting the GHX Exchange. Customers may see an increase in failed Purchase Orders processing through IBR (Intelligence Business Rules) beginning September 7, at 8:42 PM MT. Once the issue is resolved, these will be automatically reprocessed. Teams are engaged and are actively working to identify and resolve the root cause. We will continue to provide frequent updates on the issue.

If you have additional questions or concerns about this disruption, or any other matter related to our technology, data or services, please contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.

Thank you,
GHX Customer Care Team
Posted Sep 08, 2026 - 08:05 MDT

Update

Dear GHX Customer,

GHX is continuing to investigate a temporary disruption affecting the GHX Exchange. Customers may see an increase in failed Purchase Orders processing through IBR (Intelligence Business Rules) beginning September 7, at 8:42 PM MT. Once the issue is resolved, impacted transactions will be automatically reprocessed. Teams are engaged and are actively working to identify and resolve the root cause. We will provide updates as more information becomes available.

If you have additional questions or concerns about this disruption, or any other matter related to our technology, data or services, please contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.

Thank you,
GHX Customer Care Team
Posted Sep 08, 2026 - 07:17 MDT

Investigating

Dear GHX Customer,

GHX is currently investigating a temporary disruption with the GHX Exchange affecting a subset of Purchase Orders processing through IBR (Intelligence Business Rules), beginning September 7, at 8:42 PM MT. Teams are engaged and are actively working to identify and resolve the root cause. We will provide updates as more information becomes available.

If you have additional questions or concerns about this disruption, or any other matter related to our technology, data or services, please contact the GHX Customer Care team at 1-800-YOUR-GHX (968-7449). You can also submit a service request online via the "Customer Support" tab on the GHX Community at www.ghx.com/community.



Thank you,
GHX Customer Care Team
Posted Sep 08, 2026 - 05:08 MDT
This incident affects: Exchange Transaction Processing and IBR (Intelligent Business Rules).