GHX Notification: The Exchange Visibility, Transaction Processing and Status updates

Incident Report for GHX - Customer Status - All

Resolved

The issue impacting transaction processing, status updates, and visibility on Exchange has been resolved as of 9:40 PM MT on November 27.
Posted Nov 28, 2025 - 10:15 MST

Monitoring

Dear GHX Customer,

The issue impacting transaction processing, status updates, and visibility on Exchange has been resolved at 9:40 PM MT on 11/27.

* Issue start time: 6:17 PM MT on 11/27
* My Exchange transaction status updates are posting in real-time
* Visibility to IBR transactions has been resolved
* Transaction processing through the Exchange is functioning in real-time with no backlog

GHX technical teams will continue to closely monitor the GHX systems. Please be assured that we highly value your partnership and appreciate your patience. GHX sincerely apologizes for any inconvenience that this issue may have caused.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Nov 27, 2025 - 22:23 MST

Investigating

Dear GHX Customer,

GHX teams have identified an issue impacting transaction processing, status updates, and visibility on the Exchange.

* Issue identified at 6:17 PM MT on 11/27
* Transaction status updates are delayed in posting to My Exchange up to 15 minutes
* Visibility to IBR transactions is impacted; users may not see parked orders
* Transaction processing through the Exchange is delayed up to 15 minutes

Our team is actively working to resolve the issue as quickly as possible. We will continue to provide updates until the issue is fully resolved.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Best regards,
GHX Support
Posted Nov 27, 2025 - 20:37 MST