GHX teams have fully resolved the issue that impacted a small subset of transactions delivered to the Exchange. All transactions sent to GHX are processing in real time. As transactions delivered to GHX between 6:40 pm MST and 11:03 pm MST on December 5 may have been affected by this issue, we recommend that customers review their GHX-posted transactions in My Exchange to ensure GHX successfully received them. We apologize for any inconvenience these delays may have caused.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/ .
Thank you,
GHX Customer Care Team 1315 W Century Dr. Suite 100 Louisville, CO 80027 Support@GHX.com 1.800.968.7449
Posted Dec 06, 2025 - 10:00 MST
Monitoring
Hello GHX Customer,
ISSUE SUMMARY:
GHX teams are continuing to investigate an issue that impacted a small subset of transactions delivered to the Exchange starting at 6:40 PM MST this evening. Currently, all transactions sent to the Exchange are processing in real time.
GHX will continue to monitor the situation and will provide additional updates as soon as they become available.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the “Customer Support” tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you,
GHX Customer Care Team 1315 W Century Dr. Suite 100 Louisville, CO 80027 1.800.968.7449
Posted Dec 05, 2025 - 23:45 MST
Investigating
Hello GHX Customer,
ISSUE SUMMARY:
GHX teams are currently troubleshooting an issue that is impacting a small subset of transactions delivered to the Exchange starting at 6:40 PM MST this evening. We will provide additional updates as soon as they become available.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the “Customer Support” tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you,
GHX Customer Care Team 1315 W Century Dr. Suite 100 Louisville, CO 80027 1.800.968.7449
Posted Dec 05, 2025 - 22:24 MST
This incident affected: Exchange Transaction Processing, CCXpert, eInvoicing Supplier, eInvoicing Provider - Application, and NuVia.