GHX System Status Message - Transaction Processing Delays

Incident Report for GHX - Customer Status - All

Monitoring

Dear GHX Customers,

Please see the Issue Summary below for additional information related to this issue.

UPDATE:

At this time, all backlogged transactions, including GFax, have been processed. If a GFax transaction hit a supplier processing rule it will potentially need supplier review.

ISSUE SUMMARY:

The root cause has not been identified, and GHX teams remain on task and are focused on resolving this issue.
We will provide an update when the issue is resolved, or at 9:00 AM Mountain Daylight Time tomorrow 7/4, depending on progress toward resolution.

If you manually submitted any delayed orders, it’s possible that duplicate orders were sent. We recommend reviewing your orders in the Exchange to ensure that there are no duplicates sent to your suppliers.

If you have any questions, need assistance, or require help with a transaction that does not appear in the Exchange as expected, please reach out to GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care Team
Posted Jul 03, 2025 - 18:20 MDT

Identified

Dear GHX Customers,

Please see the Issue Summary below for additional information related to this issue.

UPDATE:
At this time, 5:23pm Mountain, all backlogged inbound purchase orders have been processed with the exception of GFax purchase orders. We expect GFax to be cleared within the next hour and we will send an update when complete.

ISSUE SUMMARY:
The root cause has not been identified, and GHX teams remain on task and are focused on resolving this issue.

We will provide an update when the issue is resolved, or at 9:00 AM Mountain Daylight Time tomorrow 7/4, depending on progress toward resolution.

TRANSACTION IMPACT:
Most transactions continue to process through the Exchange and are delivered in real-time; however, a subset of documents, including orders sent through GFAX continue to experience delays in processing.

If you manually submitted any delayed orders, it’s possible that duplicate orders were sent. We recommend reviewing your orders in the Exchange to ensure that there are no duplicates sent to your suppliers.

If you have any questions, need assistance, or require help with a transaction that does not appear in the Exchange as expected, please reach out to GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care Team
Posted Jul 03, 2025 - 17:28 MDT

Investigating

Good Afternoon,

The GHX teams are actively monitoring the issue that caused delays in transactions through the Exchange. While most transactions are being processed in real time, a small number of documents may experience delays, including orders through GFAX. We sincerely apologize for any inconvenience this may have caused.

If you manually submitted any delayed orders, it's possible that duplicate orders were sent. We recommend reviewing your orders in the Exchange to ensure that there were no duplicates sent to your suppliers.

If you have any questions, need assistance, or require assistance with a transaction that does not appear in the Exchange as expected, please reach out to GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you for your understanding.

Best regards,
GHX Customer Care Team
1315 W Century Dr., Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Jul 03, 2025 - 15:43 MDT

Monitoring

Good Afternoon,

The GHX teams are actively monitoring the issue that caused delays in transactions through the Exchange. While most transactions are being processed in real time, a small number of documents may experience delays of up to 15 minutes. We sincerely apologize for any inconvenience this may have caused.

If you manually submitted any delayed orders, it's possible that duplicate orders were sent. We recommend reviewing your orders in the Exchange to ensure that there were no duplicates sent to your suppliers.

If you have any questions, need assistance, or require assistance with a transaction does not appear in the Exchange as expected, please reach out to GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you for your understanding.

Best regards,

GHX Customer Care Team
1315 W Century Dr., Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Jul 03, 2025 - 14:51 MDT

Update

Good Afternoon,

ISSUE SUMMARY:

GHX teams are continuing to troubleshoot an issue that is causing a delay in processing a subset of transactions through the Exchange, including a small portion of orders through GFax. The majority of transactions are being processed through the Exchange in real time; however, a small number of documents are still delayed by this issue.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,
GHX Customer Care Team
1315 W Century Dr.
Suite 100 Louisville, CO 80027
1.800.968.7449
Posted Jul 03, 2025 - 13:33 MDT

Update

Good Afternoon,

ISSUE SUMMARY:

GHX teams are continuing to troubleshoot an issue that is causing a delay in processing a subset of transactions through the Exchange. The majority of transactions are being processed through the Exchange in real time; however, a small number of documents are still delayed by this issue.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,
GHX Customer Care Team
1315 W Century Dr.
Suite 100 Louisville, CO 80027
1.800.968.7449
Posted Jul 03, 2025 - 13:02 MDT

Identified

Good Afternoon,

ISSUE SUMMARY:

GHX teams are continuing to troubleshoot an issue that is causing a delay in processing a subset of transactions through the Exchange. The majority of transactions are being processed through the Exchange in real time; however, a small number of documents are still delayed by this issue.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,
GHX Customer Care Team
1315 W Century Dr.
Suite 100 Louisville, CO 80027
1.800.968.7449
Posted Jul 03, 2025 - 12:31 MDT

Update

Good Afternoon,

ISSUE SUMMARY:

GHX teams are continuing to troubleshoot an issue that is causing a delay in processing a subset of transactions through the Exchange. The majority of transactions are processing through the Exchange in real time, however a small number of documents are still delayed by this issue.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
We will continue to send email updates until this issue has been resolved.

Thank you,
GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Jul 03, 2025 - 11:49 MDT

Update

Good Afternoon,

ISSUE SUMMARY:

GHX teams are continuing to troubleshoot an issue that is causing a delay in processing a subset of transactions through the Exchange. The majority of impacted transactions have cleared, and the remaining queues continue to decrease quickly, however a small subset of documents are still being impacted by this issue.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
We will continue to send email updates until this issue has been resolved.

Thank you,
GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Jul 03, 2025 - 11:04 MDT

Investigating

Good Afternoon,

ISSUE SUMMARY:

GHX teams are continuing to troubleshoot an issue that is causing a delay in processing a subset of transactions through the Exchange. The majority of impacted transactions have cleared, and the remaining queues continue to decrease quickly.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,
GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Jul 03, 2025 - 10:35 MDT

Identified

Good Afternoon,

ISSUE SUMMARY:

GHX teams are currently troubleshooting an issue that is causing a delay to a subset of transactions processing through the Exchange. This potentially includes Orders, Order Confirmations, Advanced Ship Notifications and Invoices.

GHX resources are currently troubleshooting this issue.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Jul 03, 2025 - 09:59 MDT
This incident affects: G-Fax and Exchange Transaction Processing.