GHX Application Status Message - My Exchange Slowness

Incident Report for GHX - Customer Status - All

Monitoring

Good Morning,

The following notification is being sent to all GHX customers:

ISSUE SUMMARY:

Starting at approximately 8:34 am MST this morning, GHX users reported slowness within the 'My Exchange' website. At this time, the 'My Exchange' slowness experienced by users has been resolved; however, GHX technical teams will continue to closely monitor GHX systems. GHX Exchange document processing was not affected by this issue.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/ .

Thank you,

GHX Customer Care Team
1315 W Century Dr. Suite 100
Louisville, CO 80027
1.800.968.7449
Posted Nov 12, 2025 - 10:35 MST
This incident affects: My Exchange Provider and My Exchange Website.