You are receiving this email because you are an Administrator for your account or have requested to be included in incident communications. Please ensure the necessary users in your organization are informed of the information below.
Status Update: The backlog of POHX processing that started on the evening of 9/2/25 has been cleared, and all PO history files should now be processed within the expected SLA. A small subset of invoices that were processed during the time that the PO history processing was backlogged may not have been smoothed, and some invoices may require manual updates in the advanced application. Thank you very much for your patience and understanding.
If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care
Posted Sep 05, 2025 - 09:24 MDT
Update
Dear Valued eInvoicing Provider Customer,
You are receiving this email because you are an Administrator for your account or have requested to be included in incident communications. Please ensure the necessary users in your organization are informed of the information below.
Status Update: As reported on 9/3/25, an issue occurred on the evening of 9/2/25, causing a delay in processing PO history records. A small subset of Invoices may not have been smoothed, and some invoices may require manual updates in the advanced application until the PO history is fully up to date. We continue to monitor the system's progress on the backlog and will advise when PO history processing is caught up. GHX is aware of the difficulties this is causing. Please know that we value highly your partnership and patience.
If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care
Posted Sep 04, 2025 - 16:49 MDT
Update
Dear Valued eInvoicing Provider Customer,
You are receiving this email because you are an Administrator for your account, or you have requested be included on incident communications. Please ensure the necessary users in your organization are informed of the information below.
Issue Description:
As reported on 9/3/25, an issue occurred on the evening of 9/2/25, causing a delay in processing PO history records. A small subset of Invoices may not have been smoothed, and some invoices may require manual updates in the advanced application until the PO history is fully up to date. We continue to monitor the system's progress on the backlog and will advise when PO history processing is caught up.
GHX is aware of the difficulties this is causing. Please know that we value highly your partnership and patience.
If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care
Posted Sep 04, 2025 - 10:00 MDT
Update
Dear Valued eInvoicing Provider Customer,
You are receiving this email because you are an Administrator for your account or have requested to be included in incident communications. Please ensure the necessary users in your organization are informed of the information below.
Issue Description: As reported this morning, an issue occurred on the evening of 9/2/25, causing a delay in processing PO history records. A small subset of Invoices may not have been smoothed, and some invoices may require manual updates in the advanced application until the PO history is fully up to date. We are monitoring the system’s progress on the backlog and will advise when PO history processing is caught up.
GHX is aware of the difficulties this is causing. Please know that we value highly your partnership and patience.
If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care
Posted Sep 03, 2025 - 16:46 MDT
Monitoring
Dear Valued eInvoicing Provider Customer,
You are receiving this email because you are an Administrator for your account, or you have requested to be included in incident communications. Please ensure the necessary users in your organization are informed of the information below.
Issue Description: An issue occurred on the evening of 9/2/25, causing a delay in processing PO history records. Invoices sent between 9 PM MT and this morning may not have been smoothed, and invoices may require manual updates in the advanced application. We are monitoring the system’s progress on the backlog and will advise when PO history processing is caught up.
GHX is aware of the difficulties this is causing. Please know that we value highly your partnership and patience.
If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care
Posted Sep 03, 2025 - 10:12 MDT
This incident affected: eInvoicing Provider - Application.