eInvoicing Provider Advanced Application - Load Delays

Incident Report for GHX - Customer Status - All

Update

Dear Valued eInvoicing Provider Customer,

You are receiving this email because you are an Administrator for your account, or you have requested be included on incident communications. Please ensure the necessary users in your organization are informed of the information below.

GHX is aware that clients are still experiencing slower response times than normal within the eInvoicing Provider Advanced application. Our team is actively working to resolve this issue. GHX will provide updates on the progress toward a resolution as more information becomes available.

GHX is aware of the difficulties this is causing. Please know that we value highly your partnership and patience.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care
Posted Jul 29, 2025 - 16:51 MDT

Investigating

Dear Valued eInvoicing Provider Customer,

You are receiving this email because you are an Administrator for your account, or you have requested be included on incident communications. Please ensure the necessary users in your organization are informed of the information below.

Issue Description: We have received reports from clients experiencing slower response times with the eInvoicing Provider Advanced application. Our team is aware of this issue and is actively working to resolve it. GHX will provide updates on the progress toward a resolution as more information becomes available.

GHX is aware of the difficulties this is causing. Please know that we value highly your partnership and patience.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care
Posted Jul 16, 2025 - 15:51 MDT
This incident affects: eInvoicing Provider - Application.