GHX teams have isolated the issue and have successfully restored Exchange services at 10:28 PM MDT. Transaction processing is now operating in real time. New inbound Orders, Order Confirmations, Advanced Ship Notices (ASNs), and Invoices are processing normally and are no longer impacted.
Our teams have successfully processed the backlog of documents that accumulated during the incident. Document visibility within My Exchange, Procure, NuVia, E-Invoicing, IBR, Metatrade, and GFax has been restored.
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care Team 1315 W Century Dr. Suite 100
Posted Jul 16, 2026 - 22:44 MDT
Update
Dear GHX Customer,
ISSUE UPDATE:
GHX teams continue to actively work toward resolution of an issue that began at approximately 8:07 PM MDT, impacting transaction processing through the Exchange. This includes Orders, Order Confirmations, Advanced Ship Notices (ASNs), and Invoices.
GHX application visibility remains impacted due to document processing delays. Affected applications include My Exchange, Procure, NuVia, E-Invoicing, IBR, Metatrade, and GFax.
Our teams remain fully engaged in the investigation and resolution efforts. We will continue to send email updates until this issue has been resolved. There is currently no Estimated Time to Repair (ETR).
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449) or submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you,
GHX Customer Care Team 1315 W Century Dr. Suite 100
Posted Jul 16, 2026 - 22:19 MDT
Investigating
Dear GHX Customer,
ISSUE SUMMARY:
GHX teams are currently troubleshooting an issue that began at approximately 8:07 PM MDT and is impacting transaction processing through the Exchange. This includes Orders, Order Confirmations, Advanced Ship Notifications, and Invoices.
GHX application visibility is also impacted by document processing delays. Affected applications include: My Exchange, Procure, NuVia, E-Invoicing, IBR, Metatrade, and GFax. There is currently no ETR (Estimated Time to Repair).
If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.
We will continue to send email updates until this issue has been resolved.
Thank you,
GHX Customer Care Team 1315 W Century Dr. Suite 100 Louisville, CO 80027 1.800.968.7449
Posted Jul 16, 2026 - 21:18 MDT
This incident affected: My Exchange Provider, G-Fax, Exchange Transaction Processing, Procure, CCXpert, IBR (Intelligent Business Rules), eInvoicing Supplier, eInvoicing Provider - Application, NuVia, and CPlus 4.0.