You are receiving this email because you are an Administrator for your account, or you have requested be included on incident communications. Please ensure the necessary users in your organization are informed of the information below.
Issue Description: Last night, the auto-release feature in the eInvoicing Advanced application started experiencing delays.
This issue has been resolved. Auto-release functionality in the eInvoicing Advanced application will continue to release invoices on schedule three times a day.
If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.
Thank you, GHX Customer Care
Posted Dec 03, 2025 - 16:20 MST
Investigating
Dear Valued eInvoicing Provider Customer,
We are contacting you because you are listed as an Administrator for your account or have requested updates regarding incidents. Please ensure that the relevant users in your organization are informed about the following information.
Issue Description: Last night, the auto-release feature in the eInvoicing Advanced application started experiencing delays.
While our team works to resolve this issue, users facing delays can manually release invoices within the eInvoicing Advanced application.
GHX understands the difficulties this situation is causing and appreciates your partnership and patience during this time.
If you have any questions or need further assistance, please do not hesitate to contact GHX Customer Service at 1-800-YOUR-GHX (1-800-968-7449). Alternatively, you can submit a service request online through the GHX Support tab on the GHX Community at [https://ghx.my.site.com/s/](https://ghx.my.site.com/s/).
Thank you for your understanding.
Best regards, GHX Customer Care
Posted Dec 03, 2025 - 11:05 MST
This incident affected: eInvoicing Provider - Application.