GHX NOTIFICATION: eInvoicing Provider, Invoice Smoothing Delay

Incident Report for GHX - Customer Status - All

Resolved

Dear Valued eInvoicing Provider Customer,

STATUS UPDATE:

GHX teams have fully resolved the issue that delayed the processing of some Purchase Order History (POH) transactions. All POH transactions sent to GHX are now being processed in real time. We apologize for any inconvenience these delays may have caused.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/ .

Thank you,
GHX Customer Care
Posted Dec 03, 2025 - 08:01 MST

Investigating

Dear Valued eInvoicing Provider Customer,

You are receiving this email because you are an Administrator for your account or have requested to be included in incident communications. Please ensure the necessary users in your organization are informed of the information below.

Issue Description:

* GHX teams have identified an issue that is causing a delay in processing Purchase Order History (POH) files.
* The backlog in POH file processing is approximately 27 hours
* Invoice Smoothing may be delayed
* Advanced Application PO Matching & Exception Handling may be delayed

We continue to monitor the system's progress on the backlog, and will advise when PO history processing is caught up.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Dec 02, 2025 - 11:04 MST
This incident affected: eInvoicing Provider - Application.