Delays in Transactions Visibility in My Exchange application

Incident Report for GHX - Customer Status - All

Resolved

Dear GHX Customer,

RESOLVED: GHX teams have resolved the issue affecting document status updates, visibility, and processing delays in My Exchange.

*Transaction processing and delivery through the Exchange are real-time.
*Visibility to document status updates appearing on My Exchange is real-time.
*Visibility to IBR Parked POs is real-time.
*Customers should be able to access My Exchange, and other applications utilizing GHX's Single Sign On portal with no issues or delays.

GHX technical teams will continue to closely monitor the GHX systems. Please be assured that we highly value your partnership and appreciate your patience. GHX sincerely apologizes for any inconvenience that this issue may have caused.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Dec 01, 2025 - 12:47 MST

Update

Dear GHX Customer,

UPDATE: GHX teams are making progress and expect the issues affecting document status updates, visibility, and processing delays in My Exchange to be resolved soon.

GHX technical teams will continue to closely monitor the GHX systems. Please be assured that we highly value your partnership and appreciate your patience. GHX sincerely apologizes for any inconvenience that this issue may have caused.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Dec 01, 2025 - 12:07 MST

Update

Dear GHX Customer,

UPDATE: GHX teams have identified the issue affecting document status updates and visibility in My Exchange and are working to restore real-time performance.

*Transaction processing and delivery through the Exchange have been experiencing intermittent delays up to 40 minutes but are processing real-time at the moment.
*Visibility to document status updates may take up to 140 minutes to appear on My Exchange
*Visibility to IBR Parked POs may be delayed.
*Customers may also experience intermittent slowness or login errors (404,504) in My Exchange, and other applications utilizing GHX's Single Sign On portal.

GHX technical teams will continue to closely monitor the GHX systems. Please be assured that we highly value your partnership and appreciate your patience. GHX sincerely apologizes for any inconvenience that this issue may have caused.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Dec 01, 2025 - 11:42 MST

Update

Dear GHX Customer,

UPDATE: GHX teams have identified the issue affecting document status updates and visibility in My Exchange and are working to restore real-time performance.

*Transaction processing and delivery through the Exchange experienced a brief delay between 10:10 and 10:30 AM MST, but is real-time now.
*Visibility to document status updates may take up to 140 minutes to appear on My Exchange
*Visibility to IBR Parked POs may be delayed.
*Customers may also experience intermittent slowness or login errors (404,504) in My Exchange

GHX technical teams will continue to closely monitor the GHX systems. Please be assured that we highly value your partnership and appreciate your patience. GHX sincerely apologizes for any inconvenience that this issue may have caused.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Dec 01, 2025 - 11:08 MST

Update

Dear GHX Customer,

UPDATE: GHX teams have identified the issue affecting document status updates and visibility in My Exchange and are working to restore real-time performance.

*Transaction processing and delivery through the Exchange is real-time with no delay
*Visibility to document status updates may take up to 90 minutes to appear on My Exchange
*Visibility to IBR Parked POs may be delayed.
*Customers may also experience intermittent slowness or login errors (504) in My Exchange

GHX technical teams will continue to closely monitor the GHX systems. Please be assured that we highly value your partnership and appreciate your patience. GHX sincerely apologizes for any inconvenience that this issue may have caused.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Dec 01, 2025 - 10:25 MST

Identified

Dear GHX Customer

UPDATE: GHX teams have identified the issue impacting transaction status updates and visibility on the My Exchange application and are working to restore real-time performance.

*Transaction status updates may take up to 30 minutes to appear on My Exchange
*Visibility to IBR transactions may be delayed
*Customers may also experience intermittent slowness or login errors in My Exchange
*Transaction processing and delivery through the Exchange is real-time with no delay

GHX technical teams will continue to closely monitor the GHX systems. Please be assured that we highly value your partnership and appreciate your patience. GHX sincerely apologizes for any inconvenience that this issue may have caused.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,
GHX Customer Care
Posted Dec 01, 2025 - 09:28 MST

Investigating

Dear GHX Customer,

GHX teams identified an issue on 12/1, impacting transaction status updates, and visibility on the Exchange. Transaction status updates may be delayed in posting to My Exchange by up to 15 minutes. Visibility to IBR transactions is impacted; users may not see parked orders.

Our team is actively working to resolve the issue as quickly as possible. We will continue to provide updates until the issue is fully resolved.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Best regards,
GHX Support
Posted Dec 01, 2025 - 07:25 MST
This incident affected: My Exchange Provider, Exchange Transaction Processing, Procure, CCXpert, IBR (Intelligent Business Rules), NuVia, My Exchange Website, Registration Center, Provider Intelligence, and Supply Chain Analytics.