GHX Notification: The Exchange Visibility and Transaction Status updates

Incident Report for GHX - Customer Status - All

Resolved

Dear GHX Customer,

The issue impacting transaction status updates and visibility on the Exchange has been resolved.

ISSUE UPDATE:

* Issue start time: 6:15 AM Mountain Time
* My Exchange transaction status updates are now real-time
* Intelligent Business Rules (IBR) transactions are visible and able to be released

We apologize for any inconvenience this issue may have caused you and your team.

Thank you,
GHX Customer Care
Posted Nov 26, 2025 - 07:57 MST

Update

We are continuing to investigate this issue.
Posted Nov 26, 2025 - 07:55 MST

Investigating

Dear GHX Customer,

GHX teams have identified an issue affecting transaction status updates and visibility on the Exchange.

ISSUE SUMMARY:

* Issue start time: 6:15 AM Mountain Time
* Transaction status updates delayed in posting to My Exchange, up to 15 minutes behind
* Visibility to IBR transactions is impacted, users may not see parked orders

Our team is actively working to resolve the issue as quickly as possible. We will continue to provide updates every 30 minutes until the issue is fully resolved.

If you have any questions or require additional support, please contact GHX Customer Service at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the GHX Support tab on the GHX Community at https://ghx.my.site.com/s/.

Best regards,
GHX Support
Posted Nov 26, 2025 - 07:26 MST
This incident affected: My Exchange Provider, Exchange Transaction Processing, IBR (Intelligent Business Rules), and My Exchange Website.