eInvoicing Provider Advanced Application - Invoice and PO Data Delays

Incident Report for GHX - Customer Status - All

Resolved

Dear Valued eInvoicing Provider Customer,

GHX teams have resolved the issue that caused a delay in the availability of invoice and PO data in the application, beginning on April 17th at approximately 7 PM MT. All impacted documents have been processed into the application.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care Team
1.800.968.7449
Posted Apr 22, 2026 - 11:45 MDT

Monitoring

Dear Valued eInvoicing Provider Customer,

GHX teams have identified the issue that caused a delay in the availability of invoice and PO data in the application, beginning on April 17th at approximately 7 PM MT. Impacted documents are currently processing into the application and will continue to load overnight. We will continue to send email updates until this issue has been resolved.

GHX is aware of the difficulties this is causing. Please know that we value highly your partnership and patience.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

Thank you,

GHX Customer Care Team
1.800.968.7449
Posted Apr 20, 2026 - 18:58 MDT

Investigating

Dear Valued eInvoicing Provider Customer,

You are receiving this email because you are an Administrator for your account, or you have requested be included on incident communications. Please ensure the necessary users in your organization are informed of the information below.

GHX teams are currently troubleshooting an issue that is causing a delay in invoice and PO data being available in the application, beginning on April 17th at approximately 7 PM MT.

GHX is aware of the difficulties this is causing. Please know that we value highly your partnership and patience.

If you have any questions or need assistance, please contact GHX Customer Care at 1-800-YOUR-GHX (800-968-7449), or you can submit a service request online via the "Customer Support" tab on the GHX Community at https://ghx.my.site.com/s/.

We will continue to send email updates until this issue has been resolved.

Thank you,

GHX Customer Care Team
1.800.968.7449
Posted Apr 20, 2026 - 11:34 MDT
This incident affected: eInvoicing Provider - Application.